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File Menu
Use the scroll bar to see more commands. 

New Ctrl+N
Opens an empty WAVE format file for recording. When you choose New, you are 

prompted to save the file you have been working on, if it has been changed.

Open Ctrl+O
Opens an existing WAVE format file. Before opening a file, you are prompted to save 

the file you have been working on, if it has been changed.

Save Ctrl+S
Saves changes to the file you have been working on. After using Save, the file 

remains open so you can continue working on it. If the file is Untitled, you are prompted to 
name the file before saving. The file is saved in standard Windows WAVE format. The 
current compression format is recorded in the header of the file for use during playback.

Save As
Saves a new or existing file. You can name a new file or save an existing file under a 

new name. The original file remains unchanged. After using Save As, the file remains open
so you can continue working on it. 

Exit Alt+F4
Closes the file you have been working on and quits Sound Station. You are prompted 

to save any changes to the file before quitting. 



Edit Menu

Use the scroll bar to see more commands. 

Undo Ctrl+Z
Undoes your last editing action, including cut and paste actions. If an action cannot 

be undone, Undo appears dimmed on the Edit menu. 

Cut Ctrl+X
Deletes the marked audio from the file and places it into a temporary Clip file, 

replacing the previous Clip file contents. The audio remains in the Clip file until Sound 
Station cuts or copies other audio data, or until Sound Station is exited, at which time the 
Clip file is deleted. You can use Paste to copy the audio back into the file at a different 
place, or into a different file (if loaded without exiting Sound Station). If no audio is marked,
Cut appears dimmed on the Edit menu.

Copy Ctrl+C
Copies the marked audio from the file into a temporary Clip file, leaving the original 

data intact and replacing the previous Clip file contents. The audio remains in the Clip file 
until Sound Station cuts or copies other audio data, or until Sound Station is exited, at 
which time the Clip file is deleted. You can use Paste to copy the audio back into the file at 
a different place, or into a different file (if loaded without exiting Sound Station). If no audio
is marked, Copy appears dimmed on the Edit menu.

Paste Ctrl+V
Copies (pastes) audio from the Clip file to the file at the current insertion point or 

replaces marked audio in the file. The Clip file audio can come from either the current file or
an earlier Sound Station document (loaded within the same Sound Station session). If the 
Clip data is from a different audio file, the audio format (compression) of the Clip audio 
must match the format of the destination file. You can use Paste multiple times to 
duplicate a section of audio many times. Paste can also be used to transfer audio from one
audio file to another. If no Clip file audio is available, Paste appears dimmed on the Edit 
menu.

Delete Del
Deletes marked audio from the file, but does not place the audio into the Clip file. Use

Delete when you want to delete audio from the current Sound Station file but you have 
audio in the Clip file that you want to keep. If no audio is marked, Delete appears dimmed 
on the Edit menu.



Options Menu

Use the scroll bar to see more commands. 

Recording Format...
This menu entry displays the Recording Format dialog box.    This dialog allows the 

user to specify parameters for the next 'New' recording. Parameters include the type of 
compression, data size, and mono or stereo operation (where applicable).

Display in Samples / Display as Time
This menu entry determines the format of the information displayed by Sound 

Station. 
Selecting this entry when it reads 'Display in Samples' will cause Sound Station to 

display the file Length, cursor Position, and marked Start and Stop position in audio 
samples. The menu entry will be changed to 'Display as Time'.

Selecting this entry when it reads 'Display as Time' will cause Sound Station to 
display the file Length, cursor Position, and marked Start and Stop position in minutes, 
seconds, and tenths of seconds. The menu entry will be changed to 'Display in Samples'.

Disable Undo / Enable Undo
This menu entry disables or enables the creation of the Undo file.    Disabling the 

Undo file can speed operation and reduce the amount of temporary disk space required.



Help Menu
The help menu has two entries. One starts this help file, the other displays the obligatory 
ego dialog box.



What Is Sound Station ( A Graphical Tour)

Sound Station is an audio file playback and recording utility with OLE 1.0 capability.    Sound
Station allows users to record and playback voice and music in normal or compressed form.
The OLE capability of Sound Station allows the user to add voice annotation to Word 
Processor and Spread Sheet documents, or any other document that supports OLE.
Click the left mouse button on the area of the Sound Station display that you are interested
in.



Default Recording Format ( A Graphical Tour)
Click the left mouse button on the area of the Default Recording Format dialog box that you
are interested in.



Untitled
An untitled audio file is the file created when Sound Station is started without a filename on
the command line, or when New is chosen from the File menu. It must be given a filename 
before it can be saved.



Clip File
Sound Station creates a temporary file to hold audio data that has been cut or copied using
the Edit menu. The Paste command on the Edit menu can be used to transfer this 
information to the current cursor position if the Clip file data format is compatible with the 
current file data format. The temporary Clip file is deleted when Sound Station is exited.



Undo File
Sound Station copies the current audio file to a temporary file each time an Edit menu 
operation is performed.    These operations include Record, Cut, Paste, and Delete.    If the 
Undo entry on the Edit menu is dimmed, there is no undo information available. The 
temporary Undo file is deleted when Sound Station is exited.



Marked Blocks
A marked block is a length of audio samples highlighted in reverse video (blue waveform on
dark gray background). A marked block is created by holding the left mouse button down 
and dragging the mouse while the mouse pointer is in the waveform display. The mouse 
pointer becomes the Wave Edit Pointer when marking is enabled. 
Marked blocks are affected by Edit menu operations such as Cut, Copy, Del, and Paste. If 
a marked block is present, the Play command plays only the marked audio.



Sound Station Controls
Use the scroll bar to see more commands. 

Play
If a valid audio file is loaded, the entire file or marked portion is played.    If no file is 

loaded, or a file incompatible with the current WAVE driver is loaded, this button is gray.

Stop
If audio is in progress, it is halted.    The Wave Edit Cursor is moved to the beginning 

of the file (leftmost on the waveform display) or marked block, if any exists. If audio is not in 
progress, this button is gray.

Rewind
If audio is in progress, it is halted.    The Wave Edit Cursor is moved to the beginning 

of the file (leftmost on the waveform display), and any marked area is unmarked.

Pause/Resume
If Sound Station is playing or recording, the operation is paused.    If the operation is 

already paused, it is resumed. If audio a playback or recording operation has not been 
started, this button is gray.

Record
Begin recording operation.    For new files, the default recording format selections are 

used. If an audio file is already loaded, it is cleared and a new recording is made using the 
same parameters as the loaded file. If a playback operation is in progress, or the WAVE 
driver is not capable of recording in the selected format, this button is gray.

Wave Edit Pointer
When the mouse pointer is in the waveform display of an editable waveform, it takes 

the shape of the Wave Edit Pointer. Click the left mouse button with the Wave Edit Pointer at 
the desired location on the waveform to set the Wave Edit Cursor. Click and hold the left 
mouse button, then drag the Wave Edit Pointer left or right to define a marked area for 
playback or Edit menu operations.

Wave Edit Cursor
The Wave Edit Cursor is a vertical line in the waveform display that determines the 

start position for playback or insertion of paste data, and is the anchor position for marked 
blocks used in Edit menu operations.

Audio Position Scroll Bar
The position scroll bar is located directly beneath the waveform display. Click on the 

left or right arrows to move the Wave Edit Cursor in the indicated direction. Click and hold 
the left mouse button on the scroll bar 'thumb', then drag and release at the desired 
position. The scroll bar is useful for positioning when non-displayable audio formats are 
loaded.

Volume Scroll Bar
The Volume scroll bar is located immediately to the right of the waveform display. 

Click on the up or down arrows to increase or decrease playback volume. Click and hold the 
left mouse button on the scroll bar 'thumb', then drag and release at the desired position.





Play
If a valid audio file is loaded, the entire file or marked portion is 
played.    If no file is loaded, or a file incompatible with the current 
WAVE driver is loaded, this button is gray.

Stop
If audio is in progress, it is halted.    The Wave Edit Cursor is moved 
to the beginning of the file (leftmost on the waveform display) or 
marked block, if any exists. If audio is not in progress, this button is 
gray.

Rewind
If audio is in progress, it is halted.    The Wave Edit Cursor is moved 
to the beginning of the file (leftmost on the waveform display), and 
any marked area is unmarked.

Pause/Resume
If Sound Station is playing or recording, the operation is paused.    If 
the operation is already paused, it is resumed. If audio a playback 
or recording operation has not been started, this button is gray.

Record
Begin recording operation.    For new files, the default recording 
format selections are used. If an audio file is already loaded, it is 
cleared and a new recording is made using the same parameters as
the loaded file. If a playback operation is in progress, or the WAVE 
driver is not capable of recording in the selected format, this button
is gray.

Audio Position Scroll Bar
Click on the left or right arrows to move the Wave Edit Cursor in 
the indicated direction. Click and hold the left mouse button on 
the scroll bar 'thumb', then drag and release at the desired 
position. The scroll bar is useful for positioning when non-
displayable audio formats are loaded.



Volume Scroll Bar
Click on the up or down arrows to increase or decrease playback 
volume. Click and hold the left mouse button on the scroll bar 
'thumb', then drag and release at the desired position.

Wave Edit Pointer
When the mouse pointer is in the waveform display of an editable 
waveform, it takes the shape of the Wave Edit Pointer. Click the left 
mouse button with the Wave Edit Pointer at the desired location on 
the waveform to set the Wave Edit Cursor. Click and hold the left 
mouse button, then drag the Wave Edit Pointer left or right to define 
a marked block for playback or Edit menu operations.

Wave Edit Cursor
The Wave Edit Cursor is a vertical line in the waveform display that determines the start 
position for playback or insertion of paste data, and is the anchor position for marked 
blocks used in Edit menu operations.



-
A dash.



Sound Station Status Display
Use the scroll bar to see more information. 

Status
Displays the current action being performed by the Sound Station.
Stopping...

Sound Station is in the process of saving the final recorded audio to disk.
Already stopping!

User clicked Stop button twice.
Playing...
Recording...

Sound Station is playing or recording an audio file.
Playback paused
Recording paused

Sound Station is paused during playing or recording an audio file.
Record limit reached

The temporary recording file has exceeded the available disk space.    
Recording is terminated, but all audio recorded up to that point is still 
available.

Saving undo information...
Copying selected audio...
Cutting selected audio...

An edit command caused Sound Station to write the current audio data to a 
temporary undo file or clip file.

Pasting audio...
Recovering undo information...

The temporary undo or clip file information is being read from disk.
Loading file...
Saving file...

Sound Station is loading or saving an audio file.
Processing data...

Sound Station is processing recorded data following the Stop command.

When Sound Station is idle, the current WAVE file format, sample rate, and sample 
size are displayed. If no file is loaded, the defaults specified in the Recording Format dialog 
box are shown.

Position
Displays the current position of the Wave Edit Cursor in samples or in 

minute:second:tenths format, as selected from the Options menu. See Sound Station 
Controls for information of the Wave Edit Cursor.

Start



Displays the leftmost (lowest) position of the marked block during selection 
operations. The value is displayed in samples or in minute:second:tenths format, as 
chosen from the Options menu. 

Stop
Displays the rightmost (highest) position of the marked block during selection 

operations. The value is displayed in samples or in minute:second:tenths format, as 
chosen from the Options menu. 

Length
Displays the length of the current file in samples or in minute:second:tenths 

format, as chosen from the Options menu.



Waveform
A Waveform is a graphical representation of audio information. Increasing Time is on the X 
axis, and audio amplitude (volume) is on the Y axis.



System Menu
Display the system menu, which contains commands for sizing, moving, and closing the 
Sound Station application, along with a menu entry to switch to another application.



Minimize Box
Display Sound Station as an Icon on the Windows Desktop.    The 
application stays active and may be restored to it's previous 
maximized or normal state by clicking once on the Icon and selecting
Restore from the resultant system menu, or double-clicking on the 
Icon.



File Name
Displays the name of the audio file being edited, or Untitled.



Sound Station
The name of this here application.



DSP Solutions, Inc.
DSP Solutions is a manufacturer of high quality audio peripherals for portable computing 
environments.



Current Position
Displays the current position of the edit cursor in samples or in minute:second:tenths 
format, as selected from the Options menu. The edit cursor determines the start position 
for the next play command, and the anchor position for selection operations. 



Select Start Position
Displays the leftmost (lowest) position of the marked block during selection operations. The
value is displayed in samples or in minute:second:tenths format, as chosen from the 
Options menu. 



Select Stop Position
Displays the rightmost (highest) position of the marked block during selection operations. 
The value is displayed in samples or in minute:second:tenths format, as chosen from 
the Options menu. 



Audio Length
Displays the length of the current file in samples or in minute:second:tenths format, as 
chosen from the Options menu.



Compression Format
Select the compression format for recording. The Sound Station queries the Windows 

WAVE driver for available recording formats and displays the formats available from the 
following list. To record in a format not on this list, but supported by the Windows WAVE 
driver, first load a file that was recorded in the desired format using another program.    
Then save the file to a new name using Save As..., and start recording.    The new recording 
will overwrite the previous contents and will be in the same format.

PCM (Pulse Code Modulation) 

The standard recording format, and produces the best quality sound (16-bit is tops) 
but uses the most disk space.    16-bit PCM is the highest quality recording format 
available.

A Law PCM
Mu Law PCM

MuLaw and ALaw formats sound better than 8-bit PCM, but use the same amount of 
disk space. 

All other formats save on disk space, but result in lower sound quality. You must 
experiment to determine the best compromise.

IBM CVSD

CVSD compression is available in rates from 1800 bytes per second to 4800 bytes per
second. This older compression is used primarily for compatibility with older 
educational programs.

OKI ADPCM (ADaptive Pulse Code Modulation)

This 4-bit per sample compression results in moderate quality audio files that use half
the disk space of 8-bit PCM files.

DVI (IMA) ADPCM

Slightly better than OKI ADPCM, this 4-bit per sample compression compares 
favorably with 8-bit PCM recording, but uses only half the disk space.

DigiREAL

Provides good quality reproduction of human voice while consuming only 21 percent 
of the disk space used by 8-bit PCM recording. Primarily for use in voice annotation.

DSP ADPCM

This 3-bit ADPCM provides moderate quality audio recording, but uses only 37 
percent of the disk space used by 8-bit PCM recording.



Sample Size
This control selects the number of bits per audio sample. Not all compression formats allow 
the Sample Size to be changed.



Mono
This control selects recording in Mono format (one channel).



Stereo
This control selects recording in Stereo format (two channels).



File Size per Minute
This message displays the approximate number of bytes required per minute of recording 
for the selected compression format.



File Size per Second
This message displays the approximate number of bytes required per second of recording 
for the selected compression format.



Sampling Rate
This control allows selection of the number of audio samples recorded per second.



OK Button
Click on this button to accept the changes made in the Default Recording Format dialog 
box.



Cancel Button
Click on this button to return to the Sound Station main application without accepting 
changes to the Default Recording Format dialog box.



Help Button



WAVE file format
The WAVE file format refers to a file format developed by Microsoft Inc, to contain 

audio recorded in a variety of formats. WAVE files normally have an extension of .WAV.
The most common WAVE files contain uncompressed audio data called PCM (Pulse 

Code Modulation), but are not limited to that format. PCM format usually produces the best 
quality sound but uses no compression. Most other formats save on disk space, but result 
in lower sound quality. You must experiment to determine the best compromise.

All Windows compatible sound devices can play PCM WAVE files, but no single sound 
device can play all registered Windows WAVE data formats.



WAVE Driver
A Windows WAVE driver is a piece of software that is loaded when Windows starts. 

The driver translates commands from applications requesting audio recording or playback 
into the commands appropriate for the sound device installed on the computer.

The WAVE driver is supplied by the manufacturer of each sound device.    It is 
installed and setup using the Drivers applet in the Windows Control Panel (found in the 
Main Program Manager group).



Command Line Parameters
The Sound Station can load and play an audio file specified on the command line. The

following is the command line syntax for the Sound Station:

DSPSS <filename>  </O | /S>
Where:
<filename> A standard MSDOS filename, including path, for an audio WAVE file to be 

loaded by Sound Station.

/O or /o Play the loaded file once upon startup, then terminate.    The Sound Station 
window is not displayed, and the user has no control over the play. Cannot be
used with the /S flag.

/S or /s Play the loaded file upon startup. Cannot be used with the /O flag.



Questions
This section will attempt to answer questions that you may have about the operation 

of the Sound Station.

Q1) Some files display a DSP Solutions Logo instead of the waveform.
A1) Displaying data from compressed audio files does not convey any meaningful 

information. Since all DSP Solutions' products perform decompression in the 
hardware, it is inefficient to decompress the software on the PC just for display 
purposes.    The files still play, and can be manipulated via the Audio Position Scroll 
bar.

NOTE:Even though A-Law and Mu-Law formats are considered compressed, DSP Solutions 
has provided software decompression for these formats.




